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Two-Color Glow Effect

Step One:

Create a new document (File>New), and
fill the background with a solid color

(in this case, orange) by setting your
Foreground color and pressing Option- ,
Delete (PC: Alt-Backspace). Open the
object you want to apply a two-color
glow to, put a selection around the
object, get the Move tool, and drag it
onto your orange background.

Doc 531 6K/1.17M

Step Two:

Choose Outer Glow from the Add a
Layer Style pop-up menu at the bot-
tom of the Layers palette. Click on the }
beige color swatch to bring up the Color
Picker, then change the glow color to
white. Set the Blend Mode pop-up menu
to Normal, increase the Spread to 7, the
Size to 16, and click OK to apply a white
glow around your object.

Doc: 531.68/2.35M b

Step Three:

Duplicate your object layer by pressing
Command-J (PC: Control-J), then go to
the Layers palette and drag this layer
below your original layer. On this dupli-
cate layer, double-click on the words [ ] :
“Outer Glow.” In the dialog, change the _ — Outer low
glow color to a bright yellow, increase : e ' B || o ot (orma —H
the Size to 24, and click OK. This yellow r
outer glow will extend behind the white
glow, creating the double-glow effect. " ciemants
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Backscreening Objects to Make Backgrounds

Step One:

Create a new document (File>New), and
fill the background with a color (in this
case, black) by setting your Foreground
color and pressing Option-Delete (PC:
Alt-Backspace). Open the image you
want to use as a background, select just
the object in that image, and drag-and-
drop it onto the black background using
the Move tool.

Step Two:

Go to the Layers palette, and Command-

click (PC: Control-click) on the layer's
thumbnail to put a selection around
just the object on that layer. Create a
new layer, then fill this selection with

black by pressing Option-Delete (PC: Alt-

Backspace) as shown here. Deselect by
pressing Command-D (PC: Control-D).

Step Three:

In the Layers palette, lower the Opacity
of this black layer that's covering your
photo to around 70% and that image
will appear screened back into the back-
ground. | dragged-and-dropped the
same photo again, but | made it smaller
using the Free Transform command
(Mac: Command-T; PC: Control-T), so
you can see the difference between the
small foreground photo and the large
backscreened version.
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Fade-Away Reflection
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Step One:

Create a new document (File>New). Then
open the object that you want to apply
a fade-away reflection to. Put a selection
around this object, get the Move tool,
and drag the object onto your blank
document. Duplicate your object layer
by pressing Command-J (PC: Control-),
then press Command-T (PC: Control-T)
to bring up Free Transform. Control-
click (PC: Right-click) within the Free
Transform bounding box, and choose Flip
Vertical from the contextual menu.

Step Two:

Press Return (PC: Enter) to lock in your
vertical flip. Get the Move tool and
drag this flipped object straight down,
until the two bases meet. Next, go to
the Layers palette and click on the Add
a Layer Mask icon. Now you're ready
to create the reflection, so get the
Gradient tool.

Step Three:

Press Return (PC: Enter) and the Gradient
Picker will appear at the current location
of your cursor. Choose the Black to White
gradient, then take the Gradient tool,
click at the point where you want your
reflection to be completely transparent,
and drag upward until you reach the top
of the flipped object. This will create the
fade-away effect because the area where
you first clicked will become transparent,
and the area where you stopped will be
solid, with a smooth blend in between.
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Cast Shadow Effect

Step One:

Open the document that has an object
you want to add a cast shadow effect
to (in this case, it's a steering wheel).
Select just your object and press Shift-
Command-J (PC: Shift-Control-]) to
put the object on a new layer. Duplicate
the object layer by pressing Command-)
(PC: Control-J). This duplicate layer
will become the cast shadow in the
next steps.

Step Two:

Make black your Foreground color, and
press Shift-Option-Delete (PC: Shift-Alt-
Backspace) to fill the object on your
duplicate layer with black. Then press
Command-T (PC: Control-T) to bring up
Free Transform. Now hold the Command
key (PC: Control key), grab the top-cen-
ter point, and drag down and to the left
to skew the shadow (as if you're laying

it down) as shown here. Press Return
(PC: Enter) to lock in your skew.

Step Three:

Go to the Layers palette and lower the
Opacity of this layer to 50% (or less if
you like), then go under the Filter Menu,
under Blur, and choose Gaussian Blur.
When the dialog appears, enter 3 pix-
els (for high-res, 300-ppi images enter

12 pixels) and click OK. Then drag the
shadow layer below the object layer in
the Layers palette.
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Putting One Image Inside Another

Step One: ©© 6 . CellPhone (source) psd @ 100% (Laver 2,RGB/8H |
Open the photo that has an area
where you want to insert a different
photo (in this case, we want to put a
photo in the screen of a cell phone).
With the Rectangular Marquee tool,
draw a selection around the cell phone
window (as shown). Open the photo
you want to appear in the cell phone.
Press Command-A (PC: Control-A)

to select the entire photo, then press
Command-C (PC: Control-C) to copy
that photo into memory.

100 | Doc SIBOKSIEK  [B]

Step Two:

Go back to the phone document (your
selection will still be in place), then go
under the Edit menu and choose Paste
Into to paste the photo into your rect-
angular selection. Press Command-T
(PC: Control-T) to bring up the Free
Transform command so you can scale it
down to fit within your phone’s screen.
Press Command-Zero (PC: Control-Zero)
and the window will resize so you can [osem | becsnomism b
reach all the Free Transform handles — p—
(as shown here).

Step Three:

Grab a corner point, hold the Shift
key, and drag inward to scale your
photo down to size so it fits within the
phone’s screen. When it looks good to
you, press Return (PC: Enter) to lock
in your transformation. Choose Inner
Shadow from the Add a Layer Style
pop-up menu in the Layers palette, and
lower the Distance and Size settings
to 1. This completes the technique.
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Quick Depth of Field

Step One:

Open the photo that you want to
apply the effect to. Press Command-)
(PC: Conrtrol-)) to duplicate the
Background layer.

Step Two:

Go under the Filter menu, under Blur,
and choose Gaussian Blur. When the
dialog appears, increase the Radius to 4
pixels and click OK to put a blur over the
entire image.

Step Three:

Get the Eraser tool and choose a large,
soft-edged brush from the Brush Picker.
Start erasing over the parts of the image
that appear in the foreground (in this
case, erase over the head of the faucet
and the water). Erasing on this blurred
layer reveals the original, un-blurred
image on the Background layer.
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Blending from a Photo into a Solid Color

Doc: §31.6K/1.50M

Step One:

Create a new document (File>New), and
press Option-Delete (PC: Alt-Backspace)
to fill the background with the solid
color you'd like to blend into (in this
case, black). Then open your photo, get
the Move tool, and drag-and-drop the
photo onto your black background

(as shown here).

Step Two:

Get the Gradient tool, then press
Return (PC: Enter) to bring up the
Gradient Picker. Choose the Black to
White gradient in the Picker (it's the
third gradient in the default set of
gradients, as shown here).

Step Three:

Go to the Layers palette and click

the Add a Layer Mask icon. Click the
Gradient tool on your photo where you
want the blend to be the solid color,
then drag the tool upward, stopping at
the point where you want the blend to
begin. When you release the mouse but-
ton, the photo will blend from that point
down to the solid color you chose in
Step One.
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Fitting Your Image into Their Sign
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Step One:

Open the photo that has an area where
you want to insert your own image (in
this case, I'm going to insert my sign over
the original sign in this photo). Get the
Polygonal Lasso tool and draw a selection
around the interior of the sign.

Step Two:

Open the photo that you want to place
inside the sign (in this case, a poster with
a photo of a door). Press Command-A
(PC: Control-A) to select the entire
photo, then press Command-C (PC:
Control-C) to copy it into memory. Then
go back to the sign document and under
the Edit menu choose Paste Into. This
pastes the photo inside the selection, but
you're going to have some adjusting to
do because the sign is at an angle, and
your poster is straight. To do this, press
Command-T (PC: Control-T) to bring up
the Free Transform command.

Step Three:

Hold the Command key (PC: Control
key), grab the top-left control point of
the bounding box and drag it until it
meets the top-left corner of the sign in
the photo. Release the mouse button,
grab the top-right corner point and
drag it until it touches the top-right
corner of the original sign. Do the same
for the two bottom points. This gives
the pasted-in poster the same perspec-
tive as the sign. Return (PC: Enter) to
lock in your transformation.
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Putting a Photo into Type

Step One:

Create a new document, then get the
Type tool and type in the number “3”
(I'm using the font Bullet from House
Industries). Open the photo you want
to appear within your type (in this case,
| want the fire from the photo below to
appear inside the “3").

Step Two:

Cet the Move tool and drag this photo
over onto your number document. It will
appear just above your number “3" layer
in the Layers palette. Press Command-G
(PC: Control-G), which is the shortcut
for Create Clipping Mask, and basically
everything outside your number “3" will
be “clipped off’ and your photo will
appear within your type.

Step Three:

Now that the photo is inside your
number, you can use the Move tool to
reposition the photo within the type so
it's right where you want it. To accent
the edges, go to the Layers palette, make
your Type layer active, and choose Stroke
from the Add a Layer Style pop-up menu.
Change the Color to black, and click OK
to apply a black stroke around your type.
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Tinting a Photo

Step One:
Open the photo you want to tint.

Step Two:

At the bottom of the Layers palette,
choose Hue/Saturation from the Create
New Adjustment Layer pop-up menu
(as shown here).

Step Three:

When the Hue/Saturation dialog
appears, turn on the Colorize checkbox,
then move the Hue slider until you see
the color you want for your tint. To
make the color more intense, drag the
Saturation slider to the right. To darken
the image, drag the Lightness slider to
the left, or to lighten the image drag it to
the right. When the tint looks good to
you, click OK to apply the tint effect to
your image (as shown here).
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Soft Spotlight Effect
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Step One:

Create a new document (File>New),
choose a Foreground color, and press
Option-Delete (PC: Alt-Backspace) to fill
the background with that color. Open
the object you want to appear on the
background, put a selection around the
object, and drag it onto your background
document with the Move tool.

Step Two:

In the Layers palette, Command-click
(PC: Conrrol-click) on the Create a New
Layer icon to create a new blank layer
beneath your object layer. Get the Lasso
tool and draw a selection around the
object where you want your soft spot-
light to appear. Press “d” then “x" to set
your Foreground color to white, then
press Option-Delete (PC: Alt-Backspace)
to fill the selection with white. Now press
Command-D (PC: Control-D) to deselect.

Step Three:

Go under the Filter menu, under Blur, and
choose Gaussian Blur. Enter 50 pixels (try
170 pixels for high-res, 300-ppi images)
and click OK to soften the white area
enough that it looks like a soft spotlight.
Then in the Layers palette, lower the
Opacity of this layer to around 75% so it's
not so intense and looks more realistic.
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Sepia Tone Effect
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Step One:

Open your image. You'll want to convert
your photo into a black-and-white image
with added contrast, so choose Gradient
Map from the Create New Adjustment
Layer pop-up menu at the bottom of the
Layers palette.

Step Two:

When the Gradient Map dialog appears,
click on the down-facing arrow next to
the gradient thumbnail to bring up the
Gradient Picker, and select the Black to
White gradient. Click OK so the gradient
is mapped over your photo, giving it a
very “contrasty” black-and-white effect.

Step Three:

Choose Solid Color from the Create

New Adjustment Layer pop-up menu at
the bottom of the Layers palette. When
the Color Picker appears, click on the
Custom button to bring up the Custom
Colors dialog. Choose the color you want,
then change the layer blend mode from
Normal to Color in the Layers palette to
apply the sepia tone effect to your photo.
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Ripped Edge Effect

Step One:

Open the photo you want revealed when
you apply a ripped edge effect to an
image above it. Then, open the image
you want to rip, and drag it on top of
your original photo with the Move tool.
Get the Lasso tool and draw a somewhat
jaggy selection where you want the rip
(in this case, it's around the center of the
image), then press Delete (PC: Backspace)
to knock a hole out of this top layer,
revealing the layer below.

Step Two:

To add some depth, choose Outer Glow
from the Add a Layer Style pop-up menu
at the bottom of the Layers palette.

Set the Blend Mode to Normal, change
the Size to 16, click on the beige color
swatch, and change the glow color to
black in the Color Picker. Click OK to
apply a black glow inside your ripped
area. Get the Lasso tool again, and draw
another selection just outside the ripped
area. Don't exactly trace the original rip,
but loosely follow along the edge.

Step Three:

To make this slightly larger selection
look like the paper behind the rip, press
Command-L (PC: Control-L) to bring up
Levels, then drag the bottom-left Output
Levels slider almost all the way to the
right. This lightens the selected area,
adding more depth and interest to your
ripped effect.
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Creating a Reflection in Sunglasses

ene

Step One:

Open a photo in which the subject is
wearing sunglasses. Make a selection
inside one lens using any selection

i new Sunglasses.psd @ LOOK (Background, RGB/S)

tool (here | used the Lasso tool). Open
the photo you want to appear as a
reflection in the sunglasses and press
Command-A (PC: Control-A) to
select the entire photo, then press
Command-C (PC: Control-C) to copy
that selection. I ’

Step Two:

Go back to your sunglasses document,
and under the Edit menu, choose Paste
Into. Press Command-T (PC: Control-T),
hold the Shift key, and drag a corner
point inward to scale the photo so it
fits within the lens. Press Return (PC:
Enter). Then choose Inner Shadow from
the Add a Layer Style pop-up menu at
the bottom of the Layers palette. For
Distance choose 1, for Size choose 3,
change the Angle to 120°, and click OK
to add a shadow inside the image to

make it look like it's in the lens.

El new Sunglasses.psd @ 100% (Layer 4, RGB/B)

Step Three:
In the Layers palette, lower the Opacity
of this layer to around 50% and change

the blend mode to Screen so you can see
a lictle detail and some of the light source
through the lens. (Note: If both lenses are

showing in your sunglasses image, apply
the same technique to the other lens.)
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Check out more Photoshop tutorials
at these websites:

www.planetphotoshop.com
www.photoshopcafe.com
www.layersmagazine.com

www.adobe.com/designcenter
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